Timeweb [Проблема с WebHook]

← К списку тем

Добрый день !
Возникла весьма странная проблема , никак не могу разобраться с веб хуком
Для примера использую код из статьи про магазин в телеграмме
Сам WebHook установил,проблем с этим нет
Но если вызвать команду getWebhookInfo выдает такую ошибку
 {"ok":true,"result":{"url":"ПУТЬ ДО INDEX.PHP","has_custom_certificate":false,"pending_update_count":0,"last_error_date":1584918950,"last_error_message":"Wrong response from the webhook: 500 Internal Server Error","max_connections":40}}
Gleb Ivanov 23.03.2020 в 14:59

Авторизуйтесь через Telegram, чтобы ответить.
Откройте бот @SiteAuthBot, нажмите кнопку Старт/Start. Следуйте инструкциям бота.


Ответы

  • Ошибка на вашей стороне. Посмотрите логи на сервере. Проверьте соединение с БД.
    iMakeBots 23.03.2020 в 15:01
    • Да, я тоже так подумал ,поэтому включил логирование
      Все что выдает лог PHP это :
      Warning: array_key_exists() expects parameter 2 to be array, null given in /home/c/cj28649/korto/public_html/bot/index.php on line 62<br />
      <br />
      Warning: array_key_exists() expects parameter 2 to be array, null given in /home/c/cj28649/korto/public_html/bot/index.php on line 132

      С бд связь налажена , проблем нет
      Gleb Ivanov 23.03.2020 в 15:05
      • Какая версия php у вас включена для сайта?
        iMakeBots 23.03.2020 в 15:06
        • 7.2
          Gleb Ivanov 23.03.2020 в 15:09
      • Версию бота из статьи какой части используете?
        iMakeBots 23.03.2020 в 15:13
        • 4,последняя

          Проблема решилась странным образом ,написал в поддержку Timeweb по поводу ошибки с БД и PHP
          Цитирую " Мы обновили конфигурацию phpMyAdmin, теперь не должно возникнуть проблем "
          И все заработало
          Gleb Ivanov 23.03.2020 в 15:18
          • Странно при чем тут phpMyAdmin ))
            iMakeBots 23.03.2020 в 15:19
            • Я без понятия )
              У них в последнее время много странного происходит
              Gleb Ivanov 23.03.2020 в 15:20